티스토리 뷰

지난 한 달 동안, 한국인터넷진흥원(KISA)의 보안공지와 이스트시큐리티 알약 블로그에 올라올만큼,

매우 중요하다고 할 수 있는 리눅스(Linux) 관련 취약점들에 대한 간략한 정리입니다.




1. Sudo 결점, 제한된 리눅스 사용자가 루트 권한으로 명령 실행하도록 허용해


- Sudo Flaw Lets Linux Users Run Commands As Root Even When They're Restricted

- CVE-2019-14287


거의 모든 Unix 및 Linux 기반 OS에 핵심 커맨드로써 설치되어 출시되는 가장 중요하고 강력하며 흔하게 사용되는 유틸리티 중 하나인 Sudo에서 취약점이 발견되었습니다.


문제의 취약점은 Sudo의 보안 정책 우회 이슈로 악성 사용자나 프로그램이 “sudoers 구성”이 명시적으로 루트 접근을 허용하지 않을 때에도 루트 권한으로 임의 명령을 실행할 수 있도록 허용합니다.


 * 보다 자세한 내용은 https://la-nube.tistory.com/743




2. 안드로이드OS, 리눅스 블루투스 취약점 보안 업데이트 권고


- CVE-2019-9506


블루투스 프로토콜에서 발생하는 취약점을 해결한 보안 업데이트 발표

낮은 버전을 사용 중인 OS 사용자는 해결 방안에 따라 최신 버전으로 업데이트 권고


블루투스 프로토콜(BR/EDR)에서 암호화 수준이 낮은 키 길이를 허용하여 공격자가 트래픽을 도청하고 변조할 수 있는 정보노출 취약점


 * 보다 자세한 내용은 https://la-nube.tistory.com/744




3. 시스템 전체를 해킹하도록 허용하는 치명적인 리눅스 Wi-Fi 버그 발견


- A critical Linux Wi-Fi bug could be exploited to fully compromise systems

- CVE-2019-17666


GitHub의 수석 보안 엔지니어인 Nico Waisman이 리눅스의 치명적인 결함을 발견했습니다. CVE-2019-17666으로 등록된 이 취약점은 악용될 경우 공격자가 취약한 기기 전체를 해킹할 수 있게 됩니다.


이 취약점은 리눅스 커널 5.3.6 및 이전 버전에 영향을 미칩니다. 연구원들에 따르면, 이 문제는 최소 2015년부터 존재해왔습니다.


 * 보다 자세한 내용은 https://la-nube.tistory.com/745




다음은 리눅스에만 영향을 미치는 취약점이 아닌,

Chrome과 Chromium 계열의 브라우저 PC 버전을 사용한다면

리눅스를 포함하여 모든 운영체제에서 취약할 수 있는 부분입니다.


4. Chrome과 Chromium의 제로데이(0-day) 취약점


- CVE-2019-13720CVE-2019-13721


 * Chrome & Chromium : 제로데이(0-Day) 취약점과 보안 패치 : https://la-nube.tistory.com/749


 * 크롬(Chrome, Chromium) 계열 제로데이 취약점 패치 여부 : https://la-nube.tistory.com/751

댓글
댓글쓰기 폼