IT & Security/리눅스 :: 보안

Sudo 결점, 제한된 리눅스 사용자가 루트 권한으로 명령 실행하도록 허용해

la Nube 2019. 11. 1. 00:00
반응형

Sudo 결점, 제한된 리눅스 사용자가 루트 권한으로 명령 실행하도록 허용해

Sudo Flaw Lets Linux Users Run Commands As Root Even When They're Restricted

CVE-2019-14287


이스트시큐리티 알약 블로그 : https://blog.alyac.co.kr/2557


거의 모든 Unix 및 Linux 기반 OS에 핵심 커맨드로써 설치 되어 출시 되는 가장 중요하고 강력하며 흔하게 사용 되는 유틸리티 중 하나인 Sudo에서 취약점이 발견 되었습니다.


문제의 취약점은 Sudo의 보안 정책 우회 이슈로 악성 사용자나 프로그램이 “sudoers 구성”이 명시적으로 루트 접근을 허용하지 않을 때에도 루트 권한으로 임의 명령을 실행할 수 있도록 허용합니다.


-본문 중 일부




<Debian>


데비안 10 Buster (Stable)

 - sudo : 보안 패치가 완료된 1.8.27-1+deb10u1 버전이 배포됨 (fixed)


데비안 9 Stretch (OldStable), LMDE 3 Cindy

 - sudo : 보안 패치가 완료된 1.8.19p1-2.1+deb9u1 버전이 배포됨 (fixed)


데비안 8 Jessie (OldOldStable)

 - sudo : 보안 패치가 완료된 1.8.10p3-1+deb8u6 버전이 배포됨 (fixed)


LMDE 2 Betsy (데비안 8 기반)

 - 지원종료


데비안 7 Wheezy

 - 지원종료


https://security-tracker.debian.org/tracker/CVE-2019-14287




<Ubuntu>


우분투 18.04 LTS, 리눅스민트 19.x, 하모니카 ME 1.4

 - sudo : 보안 패치가 완료된 1.8.21p2-3ubuntu1.1 버전이 배포됨 (released)


우분투 16.04 LTS, 리눅스민트 18.x

 - sudo : 보안 패치가 완료된 1.8.16-0ubuntu1.8 버전이 배포됨 (released)


우분투 14.04 LTS, 리눅스민트 17.x

 - 지원종료


※ 하모니카와 하모니카 커뮤니티 배포판은 각각 리눅스민트 버전에 맞추면 됩니다.


https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-14287.html




보안 패치를 적용하기 위해서는 터미널에 다음과 같이 입력합니다.


<데비안과 우분투>


$ sudo apt update

$ sudo apt dist-upgrade



<리눅스민트와 하모니카>


$ sudo apt update

$ sudo apt dist-upgrade

$ sudo mintupdate-cli upgrade

반응형
1 2 3 4 5 6 7 8 9 ··· 127