티스토리 뷰

Linux APT에서 원격 공격자들이 시스템을 해킹할 수 있는 치명적인 RCE 결점 발견돼

Critical RCE Flaw in Linux APT Allows Remote Attackers to Hack Systems

CVE-2019-3462


이스트시큐리티 알약 블로그 : https://blog.alyac.co.kr/2090


Justicz에 따르면, 취약한 APT 버전들은 HTTP 리디렉트 시 특정 파라미터를 적절히 검사하지 않아 원격 MitM 공격자가 악성 컨텐츠를 인젝션하고 시스템이 변경 된 패키지를 다운로드 하도록 속일 수 있습니다.


-본문 중 일부


이스트시큐리티 알약 블로그의 이 저작물은 CC BY 4.0에 따라 이용할 수 있습니다.

공유 — 복제, 배포, 전시, 공연 및 공중송신 (포맷 변경도 포함)

변경 — 리믹스, 변형, 2차적 저작물의 작성, 영리목적으로도 이용이 가능합니다.




리눅스 패키지 매니저 APT 원격코드실행 보안 업데이트 권고

CVE-2019-3462


한국인터넷진흥원 : https://www.krcert.or.kr/data/secNoticeView.do?bulletin_writing_sequence=30149


□ 개요

 o 리눅스 운영체제에서 응용 SW 설치 또는 업데이트를 위해 사용하는 패키지 매니저(APT)에서 원격코드실행 취약점이 발견

    ※ APT(Advanced Packaging Tool) : 응용 프로그램 설치, 업데이트, 업그레이드를 수행하는 리눅스 패키지 매니저

 o 영향 받는 버전을 사용 중인 이용자는 해결 방안에 따라 최신 버전으로 업데이트 권고


□ 설명

  o APT 패키지 매니저의 HTTP 리다이렉션 패킷을 중간에서 가로채어 의도하지 않은 악성 컨텐츠를 삽입할 수 있는 취약점

    (CVE-2019-3462)


-본문 중 일부




<Debian>


데비안 9 Stretch (Stable) // LMDE 3 Cindy

 - apt : 보안 패치가 완료된 1.4.9 버전이 배포됨 (fixed)


데비안 8 Jessie (OldStable) // LMDE 2 Betsy

 - apt : 보안 패치가 완료된 1.0.9.8.5 버전이 배포됨 (fixed)


https://security-tracker.debian.org/tracker/CVE-2019-3462




<Ubuntu>


우분투 18.04 LTS // 리눅스민트 19.x

 - apt : 보안 패치가 완료된 1.6.6ubuntu0.1 버전이 배포됨 (released)


우분투 16.04 LTS // 리눅스민트 18.x

 - apt : 보안 패치가 완료된 1.2.29ubuntu0.1 버전이 배포됨 (released)


우분투 14.04 LTS // 리눅스민트 17.x

 - apt : 보안 패치가 완료된 1.0.1ubuntu2.19 버전이 배포됨 (released)


※ 하모니카와 하모니카 커뮤니티 배포판은 각각 리눅스민트 버전에 맞추면 됩니다.


https://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-3462.html




보안 패치를 적용하기 위해서는 터미널에 다음과 같이 입력합니다.


<데비안과 우분투>


$ sudo apt-get update

$ sudo apt-get dist-upgrade



<리눅스민트와 하모니카>


$ sudo apt-get update

$ sudo apt-get dist-upgrade

$ sudo mintupdate-cli upgrade


댓글
댓글쓰기 폼
Total
175,459
Today
28
Yesterday
378
«   2019/04   »
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30