티스토리 뷰

영국의 캐노니컬(Canonical)에서 개발하는 우분투(Ubuntu) 18.04 LTS Bionic Beaver와16.04 LTS Xenial Xerus, 그리고 14.04 LTS Trusty Tahr 리눅스 커널의 새로운 기능 추가나 버그 수정 또는 보안 취약점 문제를 해결한 GA 커널 4.15.0-22 버전, HWE 커널 4.13.0-43 버전, GA 커널 4.4.0-127 버전, HWE 커널 4.4.0-127 버전, GA 커널 3.13.0-149 버전이 업데이트를 통해 배포되었습니다.


*LTS : Long Term Support - 5년 간의 장기 지원
*HWE : Hardware Enablement - 하드웨어 지원 강화를 위한 커널로, 6개월마다 4번에 걸쳐 판올림하면서 지원
*GA : General Availability - 출시 당시의 커널로, 5년 간 판올림 없이 지원

--

이번 리눅스 커널 업데이트에서는 다음과 같은 다수의 보안 취약점에 대한 보안 패치가 각각 포함되어 있습니다. 특히, 다음의 CPU 관련 취약점이 새로 발표됨에 따라 이 취약점을 완화(경감)하기 위한 보안 패치가 포함되어 있습니다.

(이런 CPU 취약점은 소프트웨어로는 해결하지 못하고, 그저 완화하고 경감할 수 있을 뿐입니다.)


<인텔(Intel), AMD, ARM 등 CPU의 Spectre Variant 4 (스펙터 변종 4)>


구글과 마이크로소프트 등에서 추측적인 메모리 판독을 활용하는 마이크로프로세서가 사이드채널 공격을 통해 권한 없는 메모리 읽기를 허용할 수 있다는 사실을 발견하였습니다. (Microprocessors utilizing speculative execution of a memory read may allow unauthorized memory reads via a sidechannel attack.) 이 취약점은 Spectre Variant 4 (스펙터 변종 4)로 알려져 있습니다. 로컬 공격자는 커널 메모리를 포함하여 민감한 정보를 노출시키기 위해 이 취약점을 악용할 수 있습니다. (CVE-2018-3639)


스펙터 변종에는 변종 1, 변종 2, 변종 3, 변종 3a, 변종 4의 5종류가 있습니다.


※ Spectre Variant 4 (스펙터 변종 4) = Speculative Store Bypass (SSB) 취약점



linux (4.15.0-22.24) bionic


  * Spectre Variant 4 (스펙터 변종 4)

     - CVE-2018-3639 (powerpc)

     - CVE-2018-3639 (x86)


  * LSM Stacking prctl values should be redefined as to not collide with

    upstream prctls // CVE-2018-3639



linux-hwe (4.13.0-43.48~16.04.1) xenial


  * Spectre Variant 4 (스펙터 변종 4)

     - CVE-2018-3639 (powerpc)

     - CVE-2018-3639 (x86)


  * LSM Stacking prctl values should be redefined as to not collide with

    upstream prctls // CVE-2018-3639

  * CVE-2017-18208, CVE-2018-8822, CVE-2017-18203, CVE-2017-17449, CVE-2017-17975



linux (4.4.0-127.153) xenial // linux-lts-xenial (4.4.0-127.153~14.04.1) trusty


  * Spectre Variant 4 (스펙터 변종 4)

     - CVE-2018-3639 (powerpc)

     - CVE-2018-3639 (x86)


  * bpf_map_lookup_elem: BUG: unable to handle kernel paging request

    // CVE-2017-17862

  * Xenial update to 4.4.123 stable release // CVE-2017-16995

  * Xenial update to 4.4.122 stable release // CVE-2018-1000004


  * CVE-2017-17975, CVE-2017-18193, CVE-2017-18222, CVE-2018-1065, CVE-2018-1068, CVE-2018-1130, CVE-2018-5803, CVE-2018-7480, CVE-2018-7757, CVE-2018-7995, CVE-2018-8781, CVE-2018-8822


  * Xenial update to 4.4.118 stable release ~ Xenial update to 4.4.128 stable release



linux (3.13.0-149.199) trusty


  * Spectre Variant 4 (스펙터 변종 4)

     - CVE-2018-3639 (powerpc)

     - CVE-2018-3639 (x86)


  * CVE-2017-18208, CVE-2018-8822, CVE-2017-18221, CVE-2017-12134, CVE-2017-18203, CVE-2017-17449, CVE-2017-13220, CVE-2017-18204, CVE-2017-13305, CVE-2017-18079


자세한 업데이트 내역은 아래 링크의 Changelog 정보를 참고하기 바랍니다.


--

[영향을 받는 리눅스 커널 및 업데이트 버전]

■ 우분투 18.04 LTS Bionic Beaver

※ GA 커널 4.15 → GA 커널 4.15.0-22 버전으로 업데이트
https://usn.ubuntu.com/3652-1/


※ 2023년 4월 지원 종료 예정


--


■ 우분투 16.04 LTS Xenial Xerus / 리눅스민트 18.x / 하모니카 커뮤니티 배포판 MoorDev 1.0

※ HWE 커널 4.13 → HWE 커널 4.13.0-43 버전으로 업데이트
https://usn.ubuntu.com/3653-2/

※ GA 커널 4.4 → GA 커널 4.4.0-127 버전으로 업데이트
https://usn.ubuntu.com/3654-1/

※ 2021년 4월 지원 종료 예정

--

■ 우분투 14.04 LTS Trusty Tahr / 리눅스민트 17.x / 하모니카 2.1 Rosa

※ HWE 커널 4.4 → HWE 커널 4.4.0-127 버전으로 업데이트

https://usn.ubuntu.com/3654-2/

※ GA 커널 3.13 → GA 커널 3.13.0-149 버전으로 업데이트
https://usn.ubuntu.com/3655-1/

※ 2019년 4월 지원 종료 예정

--

■ 우분투 12.04 LTS Precise Pangolin / 리눅스민트 13 Maya

※ 2017년 4월 28일 지원 종료

--

그러므로 우분투 LTS 사용자는 터미널에서 다음의 명령어를 입력하여 최신버전으로 업데이트하기 바랍니다.
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoremove --purge && sudo apt-get autoclean

그리고 리눅스민트 및 하모니카 사용자는 '업데이트 매니저 → 메뉴 중 보기(V) → 리눅스 커널' 메뉴를 실행하여 해당하는 커널 내에서 최신버전으로 업데이트하기 바랍니다.

아울러 업데이트를 적용하기 위해서는 마지막에 반드시 재부팅을 하기 바랍니다.

--

배포판의 종류와 사용 중인 커널 버전을 알기 위해서는 터미널에서 다음의 명령어를 입력하기 바랍니다.
lsb_release -a && uname -a

--

리눅스민트 18, 18.1, 18.2, 18.3은 우분투 16.04 LTS Xenial Xerus를 변형한 배포판입니다.
리눅스민트 17, 17.1, 17.2, 17.3은 우분투 14.04 LTS Trusty Tahr를 변형한 배포판입니다.
리눅스민트 13 Maya는 우분투 12.04 LTS Precise Pangolin을 변형한 배포판입니다.
하모니카(HamoniKR) 커뮤니티 배포판 MoorDev 1.0은 리눅스민트 18.3 Sylvia를 변형한 배포판입니다.
하모니카(HamoniKR) 2.1 Rosa는 리눅스민트 17.3 Rosa를 변형한 배포판입니다.



::: 본 문서의 무단전재 및 재배포를 금지합니다 :::

댓글
댓글쓰기 폼