티스토리 뷰

영국의 캐노니컬(Canonical)에서 개발하는 우분투(Ubuntu) 14.04 LTS Trusty Tahr 리눅스 커널의 새로운 기능 추가와 버그 수정 및 보안 취약점 문제를 해결한 HWE 커널 4.4.0-112 버전이 업데이트를 통해 배포되었습니다.

*LTS : Long Term Support - 5년 간의 장기 지원
*HWE : Hardware Enablement - 하드웨어 지원 강화를 위한 커널로, 6개월마다 4번에 걸쳐 판올림하면서 지원
*GA : General Availability - 출시 당시의 커널로, 5년 간 판올림 없이 지원

--

이번 리눅스 커널 업데이트에서는 Intel, ARM, AMD CPU와 관련된 2건의 보안 취약점인 스펙터(CVE-2017-5715, CVE-2017-5753) 취약점에 대한 보안 패치가 다음과 같이 포함되어 있습니다.

linux-lts-xenial (4.4.0-112.135~14.04.1) trusty; urgency=low
  * linux-lts-xenial: 4.4.0-112.135~14.04.1 -proposed tracker (LP: #1745011)
  * linux: 4.4.0-112.135 -proposed tracker (LP: #1744244)
  * CVE-2017-5715 // CVE-2017-5753
    - x86/cpuid: Provide get_scattered_cpuid_leaf()
    - SAUCE: Fix spec_ctrl support in KVM
    - SAUCE: s390: improve cpu alternative handling for gmb and nobp
    - SAUCE: s390: print messages for gmb and nobp
    - [Config] KERNEL_NOBP=y

※ 스펙터(Spectre) : Intel CPU의 멜트다운(Meltdown) 취약점과 함께 발견된 Intel, ARM, AMD CPU의 보안 취약점으로, 악성 스크립트가 삽입된 홈페이지에 접속하는 것만으로도 취약점을 악용할 수 있는 웹 기반 공격이 가능하다고 발표됨

자세한 업데이트 내역은 아래 링크의 Changelog 정보를 참고하기 바랍니다.

--

[영향을 받는 리눅스 커널 및 업데이트 버전]

우분투 16.04 LTS Xenial Xerus / 리눅스민트 18.x / 하모니카 커뮤니티 배포판 MoorDev 1.0

※ HWE 커널 4.13 → HWE 커널 4.13.0-32 버전이 사용되고 있음을 확인
https://launchpad.net/ubuntu/+source/linux-hwe/4.13.0-32.35~16.04.1

※ GA 커널 4.4 → GA 커널 4.4.0-112 버전이 사용되고 있음을 확인
https://launchpad.net/ubuntu/+source/linux/4.4.0-112.135

※ 2021년 4월 지원 종료 예정

--

우분투 14.04 LTS Trusty Tahr / 리눅스민트 17.x / 하모니카 2.1 Rosa

※ HWE 커널 4.4 → HWE 커널 4.4.0-112 버전으로 업데이트
https://launchpad.net/ubuntu/+source/linux-lts-xenial/4.4.0-112.135~14.04.1

※ GA 커널 3.13 → GA 커널 3.13.0-141 버전이 사용되고 있음을 확인
https://launchpad.net/ubuntu/+source/linux/3.13.0-141.190

※ 2019년 4월 지원 종료 예정

--

우분투 12.04 LTS Precise Pangolin / 리눅스민트 13 Maya

※ 2017년 4월 28일 지원 종료

--

그러므로 우분투 LTS 사용자는 터미널에서 다음의 명령어를 입력하여 최신버전으로 업데이트하기 바랍니다.
$ sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get autoremove --purge && sudo apt-get autoclean

그리고 리눅스민트 및 하모니카 사용자는 '업데이트 매니저 → 메뉴 중 보기(V) → 리눅스 커널' 메뉴를 실행하여 해당하는 커널 내에서 최신버전으로 업데이트하기 바랍니다.

아울러 업데이트를 적용하기 위해서는 마지막에 반드시 재부팅을 하기 바랍니다.

--

배포판의 종류와 사용 중인 커널 버전을 알기 위해서는 터미널에서 다음의 명령어를 입력하기 바랍니다.
$ lsb_release -a && uname -a

--

리눅스민트 18, 18.1, 18.2, 18.3은 우분투 16.04 LTS Xenial Xerus를 변형한 배포판입니다.
리눅스민트 17, 17.1, 17.2, 17.3은 우분투 14.04 LTS Trusty Tahr를 변형한 배포판입니다.
리눅스민트 13 Maya는 우분투 12.04 LTS Precise Pangolin을 변형한 배포판입니다.
하모니카(HamoniKR) 커뮤니티 배포판 MoorDev 1.0은 리눅스민트 18.3 Sylvia를 변형한 배포판입니다.
하모니카(HamoniKR) 2.1 Rosa는 리눅스민트 17.3 Rosa를 변형한 배포판입니다.

댓글
댓글쓰기 폼